ASP .Net 2003 : Error while trying to run project: Unable to start debugging on the web server. Server side-error occurred on sending debug HTTP request.(HTTP/1.1 500 Internal Server Error)

My friend copied his project from another machine to his machine, project was in asp .net 2003 fromat, which was working well in old machine. But when he tried to run it(for debugging purpose) from visual studio 2003 it gave following error :
—————————
Microsoft Development Environment
—————————
Error while trying to run project: Unable to start debugging on the web server. Server side-error occurred on sending debug HTTP request.
Make sure the server is operating correctly. Verify there are no syntax errors in web.config by doing a Debug.Start Without Debugging. You may also want to refer to the ASP.NET and ATL Server debugging topic in the online documentation.
—————————
OK   Help
—————————
Even we tried to run using url http:\\localhost\virtual_dir_name\page.aspx, but it was still giving error something like ‘HTTP/1.1 500 Internal Server Error’. Finally after searching over net we found following solution at byte.com.
For us second solution worked. We did following step:
1.Deleted ASPNET windows user account (from control panel->User Accounts->Users Tab)
2.And then in command prompt(cmd, not vs command prompt) went to framework directory, i.e., in our case
C:\Windows\Microsoft.NET\Framework\v1.1.4322 and ran the command “aspnet_regiis -i” (to re-register the Framework 1.1 and reinstall ASPNET user).
And bingo !!! it worked without even restarting the machine/server.
Above solution solution also solved following problem.
We also faced the problem on creating new web project using asp.net 2003 on same machine, got the error:
—————————
Microsoft Development Environment
—————————
The Web server reported the following error when attempting to create or open the Web project located at the following URL: ‘http://localhost/WebApplication1’. ‘HTTP/1.1 500 Server Error’.
—————————
OK   Help
—————————

Reference:

Advertisements
Published in: on June 2, 2010 at 10:07 am  Comments (2)  
Tags: ,

The URI to TrackBack this entry is: https://indiandeve.wordpress.com/2010/06/02/asp-net-2003-error-while-trying-to-run-project-unable-to-start-debugging-on-the-web-server-server-side-error-occurred-on-sending-debug-http-request-http1-1-500-internal-server-error/trackback/

RSS feed for comments on this post.

2 CommentsLeave a comment

  1. Still doesnt work for me :*(

  2. Thank you. This was a great help.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: